lost plug after sweep - how long? TMI

We've Moved!

Our wonderful discussion forums have now moved to Facebook...

Click to join us in our HIGM ("Help I'm Getting Married") group!

Bun in Oven Posts: 241
Girls, Had membrane sweep yesterday and a good session of reflexology after that. All day afterwards, I had cramps like bad period pains and a heavy, aching feeling from my lower back right down into my thighs, accompanied by very intense braxton hicks (I think they were BH anyway but they were a lot stronger than other ones I've had!). I was sure labour was starting! This morning though I woke up feeling normal again; i.e. no cramps. I did lose the plug this morning though I think. However it was like a big brown goop of mucus this time and not clear like it was on my last pregnancy after a sweep, so I don't know if that's the plug. Just wondering, because the pains have died down, will things likely not happen for another good while? Thanks.
slinkyminx Posts: 650
Hey Bun In Oven, I'm the same...had a sweep on weds, then had very strong braxton hicks weds night & a dull ache very low down. Yesterday morning there was a gloop of brownish discharge, didn't know if this was my plug or just as a result of the sweep. Have been nesting like a mad thing yesterday & today, but my back is very sore....I hate this waiting game! O:| :wv
december29 Posts: 395
its just a result of the sweep have had 3 sweeps now and each time had a show. had a show seperate to this as well so assume that was my "true" show IFYWIM. am 40+8 today and still here :o)ll
blondiee Posts: 771
So exciting, best of luck to all of you :wv
1